The importlib-metadata requirements in setup.py is too strict:install_requires=[ 'importlib-metadata~=4.12; python_version < "3.10"',
I suggest to change it to read:install_requires=[ 'importlib-metadata>=4.12; python_version < "3.10"',
Simply replacing ~= by >=.
I believe there is no reason to be so strict. The current version of importlib-metadata is 6.0.0: https://pypi.org/project/importlib-metadata/